noc.cm.parsers.MikroTik.RouterOS.base

Module Contents

class noc.cm.parsers.MikroTik.RouterOS.base.RouterOSParser(managed_object)

Bases: noc.cm.parsers.pyparser.BasePyParser

rx_continue
SPEED_MAP
preprocess(self, config)
create_parser(self)
on_begin(self, tokens)
parse_kvp(self, tokens)
get_interface_fact(self, name)
get_interface_defaults(self, name)
on_set(self, tokens)
on_add(self, tokens)
on_system_identity_set(self, name, args)

/system identity set name=hostname

on_system_clock_manual_set(self, name, args)

/system clock manual set time-zone=+04:00

on_ip_service_set(self, name, args)

/ip service set telnet disabled=yes

on_system_ntp_client_set(self, name, args)

/system ntp client set enabled=yes primary-ntp=1.1.1.1 secondary-ntp=2.2.2.2

on_interface_ethernet_set(self, name, args)
on_ip_route_add(self, args)